Back to overview
Degraded

Degraded Inter-datacenter Proxy Performance

Apr 14, 2026 at 7:43pm UTC
Affected services
Residential Proxy Network

Resolved
Apr 14, 2026 at 9:44pm UTC

We have successfully resolved the recent service degradation. The root cause was identified as decreased data throughput between our EU and US datacenters, which triggered proxy errors for users routing traffic between these two regions. We sincerely apologize for the impact this had on your operations. Our engineering team has already deployed preventative network measures to avoid similar bottlenecks in the future.

Created
Apr 14, 2026 at 7:43pm UTC

We are currently investigating reports of degraded performance for proxy requests requiring inter-datacenter routing, specifically between our EU and US regions. Users on the Residential Proxy Network may experience increased latency or intermittent connection timeouts. Our engineering team is actively analyzing our cross-region network links to identify the root cause.