Back to overview
Degraded

Inter region data transfer degradation

Jun 1, 2026 at 11:45am UTC
Affected services
Residential Proxy Network
Mobile Proxy Network
Datacenter Proxy Network

Resolved
Jun 2, 2026 at 12:01pm UTC

The server provider still has a low packet loss, we have configured the infrastructure to handle everything as good as possible. We are monitoring the situation and evaluating new infrastructure decisions.

Updated
Jun 2, 2026 at 6:11am UTC

Our server provider has partially resolved their issues and the packet loss dropped from 10% to 2%.
The proxy network between regions is mostly stable and only very infrequent errors are occurring.

We are currently investigating alternative server providers.

Created
Jun 1, 2026 at 11:45am UTC

We are observing a 10% packetloss between our datacenter regions. This results in errors for proxies that are from other regions than the one you are connecting to. We are in contact with the server hoster to solve the issue.